Why am I getting a "Store of atom failed" or "Unable to store atom" errors after I upgrade my node to 1.1.0?

You have most likely set api.transactions.enabled=true in your node default.config file, but have not resynced your Radix database from the beginning.


The api.transactions.enabled=true setting adds new tables to the Radix database to support the new /transactions endpoint used by the Gateway API and Data Aggregator.

If you try to enable this flag with an existing Radix database, it fails with the error messages above. This is because the new transaction tables need to be populated with transaction data from the start of the Radix ledger.

To enable this feature, stop the Radix node, delete the contents of the Radix database directory, and start the Radix node again. The resync process may take up to 24 hours to complete.